学电脑,学计算机 | 手机访问 | 加入收藏 | 设为首页 | RSS
当前位置:首页 > 网络技术 > 交换技术 > 正文

Catalyst3550的三层交换与VLAN

发布时间:2009-06-01 01:02:50  来源:本站整理
【摘要】: Catalyst3550的三层交换与VLAN
Cisco;Catalyst 3550-24交换机包括SMI(标准版)和EMI(增强版)两个版本。Cisco Catalyst 3550-24是可堆叠的、多层企业级交换机,可以提供高水平的可用性、可扩展性、安全性和控制能力。因为具有多种快速以太网和千兆以太网配置,因此Catalyst 3550-24既可以作为功能强大的接入层交换机,用于中型企业的布线室;也可以作为一个骨干网交换机,用于中型网络。可以在网络中部署智能化的服务,如服务质量(QoS),速度限制,访问控制列表,多播治理,IP路由功能使传统的VLAN交换变得很简便。Catalyst 3550-24中嵌进了Cisco集群治理套件(CMS)软件,这软件使用户可以利用Web浏览器同时配置和诊断多个Catalyst桌面交换机并为其排除故障。Cisco CMS软件提供了简便的配置向导,能大幅度简化网络治理服务的部署。

Catalyst 3550-24交换机有24个10/100端口和两个基于千兆接口转换器(GBIC)的千兆以太网接口插槽,可以支持多种GBIC收发器。双GBIC的千兆以太网接口实施方案可以为客户提供高度的部署灵活性使客户可以部署千兆堆栈和上行链路配置。

Catalyst 3550-24中含有标准多层软件镜像(SMI)或者增强型多层软件镜像(EMI),定购号分别是:WS-C3550-24-SMI 和WS-C3550-24-EMI。而EMI提供了一组更加丰富的企业级功能,包括基于硬件的IP单播和多播路由,虚拟LAN(VLAN)间的路由,路由访问控制列表和热备用路由器协议。在刚开始部署时,增强型多层软件镜像升级工具包为用户提供了升级到EMI的灵活性。所以用户在先前购买的是Catalyst 3550-24 SMI交换机的话,要实现三层交换及以上更多功能,就要把镜像要升级至EMI版本,也就是IOS要升级到12.1(11)EA1以上。

使用Catalyst 3550-24 EMI来进行企业级组网是有好处的。它体现在:网络规模不是很大的企业级用户,可以用它来组建快速以太网;三层交换,以至轻松实现VLAN间路由,提高安全性和网络整体通信性能;并可以使用GBIC接口来实现千兆主干,这个主干可以是交换机与交换机之间的高速通道,还可以是接入服务器。

三层交换

三层交换技术就是:二层交换技术+三层转发技术。它解决了局域网中划分网段之后,网段间的通信必须依靠传统路由器进行网段间数据转发的问题,和传统路由器的基于软件算法的转发操作,所造成固有的低速而造成网络瓶颈的问题。三层交换的优势通过IP路由还能提高网络的整体性能。传统的交换机工作在网络七层模型的第二层——数据链路层,只能识别该层以下的信息,三层交换是指网络设备可以判别第三层的IP,并以此为依据实现数据的跨网段转发。交换机的三层交换可以实现原来路由器才能完成的路由功能,而数据处理的延迟却又远远低于路由器,因为交换机的路由功能是基于硬件实现,这完全不同于传统路由器的软件实现,它达到第二层交换机才有的高效率。另外随着网络中数据、语音和视频等多业务传输需要的逐渐增加,传统的二层交换的局限性就日益暴露出来,在整个完全部署二层交换机的局域网环境里,数据交换所产生的广播到处漫延,影响了用户数据的正常通信。三层交换具备的路由功能可抑制网络广播的扩散,同一网段内的广播被限制在自己的广播域里,这样就能大大提高数据的安全性。一般我们在网络治理中,都会把相同部门的主机划归同一个广播域(基于VLAN的实现),这样同个部门间主机通信时产生的广播将被限制在本部门的广播域里,有效地保证了网络的保密性和安全性。当数据要跨越网段通信时,就要用到路由来进行转发。三层交换(路由功能)就象是网络的一道闸门,它使网段内的通信广播被限制在里面,要出去则由它来代劳。因此广播被限制,广播风暴不会产生,网间路由是它的特点,这样就能实现网络通信的保密性和安全性,提高网络整体性能。

当今的企业网络需要在网络边缘满足新的业务需求,比如需要占用大量夺带的应用 ,这些新的需求将与现有的要害业务争夺带宽资源,所以需要交换机具有三层交换的功能,阻断网络广播跨网段传播。思科公司生产的这款Catalyst 3550 EMI交换机完全适合上述应用前景的需求,它利用基于硬件的IP路由可以在所有端口上提供线速路由,增强型多层软件镜像,则是一种基于WEB的程序,可以极大方便网络治理员治理,配置和修复网络,当然要所有交换机全都是思科交换机才行。第三层交换功能配合VLAN功能,可以限制广播和大幅降低网络风暴产生的机会,整体提高网络的安全和网络性能。 除了动态IP单播路由以外,Catalyst 3550交换机系列非常适用于需要支持多播环境的网络(视讯会议)。硬件中专门配备的多播路由协议(PIM)和互联网群组治理协议(IGMP)使得Catalyst 3550交换机非常适用于需要进行大量多播服务的环境里,使企业能在现在或将来有能力部署局域网内广播视讯会议。

基于CATALYST 3550-24交换机的VLAN实现案例

下面将介绍一个实例。某移动通信公司的内部办公网络有12台CATALYST 3550-24 SMI (标准版)交换机,有一台服务器。用户要求:把整个办公局域网划分成三个VLAN,要求服务器只能接受被授权访问的主机访问。正如我已经知道的那样,CATALYST 3550-24 SMI不具有三层交换功能,要使它具有三层交换功能,我们须要把它的镜像文件升级到EMI(增强版) ,IOS升级为12.1(11)EA1版本。在这个网络中我们将用一台CATALYST 3550-24 SMI来做中心交换机,所以我们希望它具有三层交换功能,因此把它升级到EMI,其它11台CATALYST 3550-24 SMI则不用升级,全部用来做接入层交换机。我们将要划分三个VLAN,也就是要划分三个网段。分别是VLAN2——网络号为192.168.2.0,指定的网关为192.168.2.1;VLAN3——网络号为192.168.3.0指定的网关为192.168.3.1;VLAN10——网络号为192.168.10.0,指定的网关为192.168.10.1,服务器在这个VLAN中。(注:由于思科的交换机在没有划分VLAN时,所有端口默认为VLAN1,所以划分VLAN一般会从VLAN2开始。)我先来看整个局域网网络的拓朴图:(见图2)

图2(点击看大图)


从上图我可以看出12台CATALYST 3550-24交换机是采用堆叠的方式连接的。最上的那台交换机已升级到EMI,其它仍为SMI。交换机之间的堆叠通过1000BaseT GBIC模块(见图3)来实现。单端口 Cisco 1000BASE-T GBIC模块能在堆叠交换机之间提供1000M的高速传输,也可用来连接服务器,或在配线间之间搭成千兆的主干连接。在这个方案中,服务器是重点保护对象,我们将禁止来自VLAN3的所有主机访问服务器。服务器就接在中心交换机的第13口上,所以我在中心交换机上设置访问控制列表(ACL),控制所有来自VLAN3的主机从这个13号端口出去。具体见以下第9。

QQRead.com 推出数据恢复指南教程 数据恢复指南教程 数据恢复故障解析 常用数据恢复方案 硬盘数据恢复教程 数据保护方法 数据恢复软件 专业数据恢复服务指南

VLAN实现的配置命令行如下:(仅供参考)

一.中心交换的VLAN配置

(1)激活vlan路由
Switch1#config t
Switch1(config)#ip routing;

(2)创建三个VLAN
Switch1#
Switch1#vlan database
Switch1(vlan)#vlan 2
Switch1(vlan)#vlan 3
Switch1(vlan)#vlan 10
Switch1(vlan)#exit

(3)给VLAN分配IP
Switch1#config t
Switch1(config)#config vlan2
Switch1(config-if)#ip address 192.168.2.1 255.255.255.0
Switch1(config-if)#no shutdown
Switch1#config t
Switch1(config)#config vlan3
Switch1(config-if)#ip address 192.168.3.1 255.255.255.0
Switch1(config-if)#no shutdown
Switch1#config t
Switch1(config)#config vlan10
Switch1(config-if)#ip address 192.168.10.1 255.255.255.0
Switch1(config-if)#no shutdown

(4)配VTP
Switch1#
Switch1#config t
Switch1(config)#vtp domain china_mobile
Switch1(config)#vtp mode server
Switch1(config)#end

(5)配Trunk
Switch1#
Switch1#config t
Switch1(config)#interface gigabitethernet0/1
Switch1(config-if)#switchport trunk encapsulation isl
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#end

(6)给中心交换机通往路由器的接口配IP
Switch1#
Switch1#config t
Switch1(config)#interface fastethernet0/1
Switch1(config-if)#no switchport
Switch1(config-if)#ip address 200.1.1.1 255.255.255.0
Switch1(config-if)#no shutdown

(7)给中心交换机配置缺省路由
Switch1#
Switch1#config t
Switch(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2

(8)把VLAN号分配给IP接口
Switch1#
Switch1#config t
Switch1(config)#interface fastethernet0/2
Switch1(config-if)#switchport mode Access
Switch1(config-if)#switchport access vlan2
Switch1(config-if)#spanning-tree portfast
… …
Switch1#
Switch1#config t
Switch1(config)#interface fastethernet0/13
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan3
Switch1(config-if)#spanning-tree portfast
(其它同)

(9)配访问控制列表ACL禁VLAN3子网的客户机访问服务器
Switch1#
Switch1#config t
Switch1(config)#access-list 1 deny 192.168.3.0 0.0.0.255
Switch1(config)#access-list 1 permit any
Switch1(config)#interface fastethernet0/13 (此接口接服务器)
Switch1(config-if)#ip access-group 1 out

(10)检查上述配置
Switch1#show vlan
Switch1#show ip route
Switch1#show interface gigabitethernet0/1 switchport
Switch1#show run

Switch1#show vtp status

(11)存配置
Switch1#copy running-config startup-config

二.在接入层交换机Swith2上VLAN的配置

(1)配TRUNK
Switch2#
Swtich2#config t
Switch2(config)#interface gigabitethernet0/1
Switch2(config-if)#switchport trunk encapsulation isl
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#end

Switch2#
Swtich2#config t
Switch2(config)#interface gigabitethernet0/2
Switch2(config-if)#switchport trunk encapsulation isl
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#end

(2)配VTP
Switch2#
Switch2#config t
Switch2(config)#vtp mode client
Switch2(config)#vtp domain china_mobile
Switch2(config)#end

(3)给接口分配VLAN号
Switch2#
Switch2#config t
Switch2(config)#interface fastethernet0/1
Switch2(config-if)#switchport mode access
Switch2(config-if)#switchport access vlan2
Switch2(config-if)#spanning-tree portfast
… …
(其它端口配置同)
(4)存配置
Switch2#copy running-config startup-config
(其它交换机同)

小结:

对于企业级的应用来说,局域网内的业务流量类型起来越多,对网络的整体性能也就提出了苟刻的要求。我们只有设计出技术优越的网络才能适应这种要求。思科CATALYST 3550 -24 EMI在QoS上性能超群,能按业务类型进行分类,以进行优先级服务,使要害性业务,带宽敏感性业务优先转发。而三层交换功能更是能完美胜任当今企业局域网越来越普遍的在交换环境中部署三层交换的需求。本案例就说明了CATALYST 3550 -24 EMI的三层交换功能很好地胜任了这种需求。


发表评论 共有条评论
验证码: