学电脑,学计算机 | 手机访问 | 加入收藏 | 设为首页 | RSS
当前位置:首页 > 网络技术 > 交换技术 > 正文

交换机配置- 使用channel方式封装子接口

发布时间:2011-10-25 14:13:33  来源:本站整理
【摘要】: 该方式下,首先将L2与L3的内部接口作成以太通道,然后,在L3上创建一个虚拟的通道接口,在该接口下开子接口为各个VLAN提供三层路由功能。

  该方式下, 首先将L2与L3的内部接口作成以太通道,然后,在L3上创建一个虚拟的通道接口,在该接口下开子接口为各个VLAN提供三层路由功能。

  在广西城域网工程中,所有的4006交换机都是采用的这种方式。关于以太通道的介绍见上文。

配置步骤:(以下假设L3模去是插在第二槽上,且使用缺省的channel协议)

① L2:set port channel mod/ports 配置GE端口。
Cat4000> (enable) set port channel 2/1-2 mode on;;;;
Ports 2/1-2 channel mode set to on.
Cat4000> (enable)
②指定同一channel的端口为相同VLAN。
Cat4000> (enable) set vlan 1 2/1-2;;;<---端口2/1-2必须属于同一VLAN
VLAN;;Mod/Ports
---- -----------------------
1;;;;;2/1-4,2/6-48
;;;;;;3/1-6
Cat4000> (enable)

③用 set trunk mod_num/port_num 打开Trunk功能并且指定封装类型
Cat4000> (enable) set trunk 2/1 on dot1Q 1-10 <----只需要在其中一个端口指定trunk即可

Port(s) 2/1 trunk mode set to on
Port(s) 2/1 trunk type set to dot1Q 1-10
Cat4000> (enable)
④利用 session mod_num 进入L3模块
Cat4000> (enable) session 2

Trying Router...
Connected to Router.
Escape character is Q^]'.
router>


⑤创建 EtherChannel (portchannel)接口,接口范围为1 到 64:
router(config)# interface port-channel channel_number

⑥将GE3和GE4端口绑到portchannel上。

router(config)# interface g3
router(config-if)# channel-group channel_number
router(config-if)# exit
router(config)# interface g4
router(config-if)# channel-group channel_number
router(config-if)# exit

⑦创建子接口和封装VLAN。
router(config)# interface port-channel channel_number.vlan_id
router(config-subif)# encapsulation dot1Q vlan_id
router(config-subif)# ip address ip_address subnet_mask
router(config-subif)# exit

重复以上步骤直到将所有的VLAN都封装完毕。
⑧ 利用 native要害字封装一个本地VLAN的子接口。需要为Trunk干道来产生一个本地VLAN子接口。注重,该native要求与L2的native vlan号相同
router(config)# interface port-channel channel_number.vlan_id
router(config-subif)# encapsulation dot1Q vlan_id native
<-------native指明此接口为本地VLAN接口
router(config-subif)# ip address ip_address subnet_mask
router(config-subif)# exit
以下是该方式的一个完整示例:
L2:(采用PAgP协议)
Set vlan 1 2/1-2
set port channel 2/1-2 mode on
set trunk 2/1;;on dot1q 1-1005
set trunk 2/2;;on dot1q 1-1005
L3:
version 12.0
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service passWord-encryption
!
hostname M-4006R-NN
!
boot system flash bootflash:cat4232-in-mz.120-18.W5.22b.bin
enable secret 5
!
interface Loopback0
ip address
no ip directed-broadcast
!
interface Port-channel1
no ip address
no ip directed-broadcast
hold-queue 300 in
!
interface Port-channel1.1
description manage-vlan
encapsulation dot1Q 1 native
no ip directed-broadcast
!
interface Port-channel1.2
description local Management
encapsulation dot1Q 2
no ip directed-broadcast
!
interface Port-channel1.76
description uplink to
encapsulation dot1Q 76
ip address XXXX
no ip directed-broadcast
!;
interface Port-channel1.201
description PPPoE test 2002.8.1
encapsulation dot1Q 201
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet1
no ip address
no ip directed-broadcast
shutdown
!
interface GigabitEthernet1
no ip address
no ip directed-broadcast
shutdown
!
interface GigabitEthernet2
no ip address
no ip directed-broadcast
shutdown
!
interface GigabitEthernet3
no ip address
no ip directed-broadcast
no negotiation auto
channel-group 1
!
interface GigabitEthernet4
no ip address
no ip directed-broadcast
no negotiation auto
channel-group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0
end

发表评论 共有条评论
验证码: