学电脑,学计算机 | 手机访问 | 加入收藏 | 设为首页 | RSS
当前位置:首页 > 网络技术 > 交换技术 > 正文

软考网络工程师复习资料(1)

发布时间:2009-06-01 00:45:19  来源:本站整理
【摘要】: 软考网络工程师复习资料(1)

练习题

习题一

NAT英文全称是“Network Address Translation”,中文意思是“网络地址转换”,它是一个IETF(Internet Engineering Task Force, Internet工程任务组)标准,答应一个整体机构以一个公用IP(Internet Protocol)地址出现在Internet上。顾名思义,它是一种把内部私有网络地址(IP地址)翻译成合法网络IP地址的技术。如图









某公司通过专线上网,申请的合法Internet IP地址192.1.1.1~192.1.1.10 ,使用路由器的NAT功能进行地址转换,具体配置如下:

Current configuration:
version 11.3
no service passWord-encryption
hostname 2501
ip nat pool aaa 192.1.1.2 192.1.1.10 netmask 255.255.255.0
ip nat inside source list 1 pool aaa
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
ip nat inside
interface Serial0
ip address 192.1.1.1 255.255.255.0
ip nat outside
no ip mroute-cache
bandwidth 2000
no fair-queue
clockrate 2000000
interface Serial1
no ip address
shutdown
no ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
Access-list 1 permit 10.1.1.0 0.0.0.255
line con 0
line aux 0
line vty 0 4
password cisco
end

【问题1】NAT按技术类型分为哪三种转换方式?
【问题2】请解释画线部分内容含义?
【问题3】此配置中采用了那种转换方式?

习题二

PPP(Point-to-Point Protocol)是SLIP(Serial Line IP protocol)的继续者,它提供了跨过同步和异步电路实现路由器到路由器(router-to-router)和主机到网络(host-to-network)的连接。
CHAP(Challenge Handshake Authentication Protocol)( 挑战-握手验证协议)和PAP(Password Authentication Protocol) (PAP)( 口令验证协议)通常被用于在PPP封装的串行线路上提供安全性认证。使用CHAP和PAP认证,每个路由器通过名字来识别,可以防止未经授权的访问。
路由器Router1和Router2的S0口均封装PPP协议,采用CHAP做认证。;
配置如下:
设置如下:
Router1:
hostname router1
username router1 password xxx
interface Serial0
ip address 192.200.10.1 255.255.255.0
encapsulation ppp
clockrate 1000000
ppp authentication chap
!
Router2:
hostname router2
username router2 password xxx
interface Serial0
ip address 192.200.10.2 255.255.255.0
encapsulation ppp
ppp authentication chap
【问题1】上述配置中是否有问题?请指出并说明理由。
【问题2】解释配置中画线部分内容含义?

习题三

X.25规范对应OSI三层,X.25的第三层描述了分组的格式及分组交换的过程。X.25的第二层由LAPB(Link Access Procedure, Balanced)实现,它定义了用于DTE/DCE连接的帧格式。X.25的第一层定义了电气和物理端口特性。
在以下实例中每二个路由器间均通过svc实现连接。

各路由器的配置如下:
Router1:
interface Serial0
encapsulation x25
ip address 192.200.10.1 255.255.255.0
x25 address 110101
x25 htc 16
x25 nvc 2
x25 map ip 192.200.10.2 110102 broadcast

;x25 map ip 192.200.10.3 110103 broadcast
!
Router2:
interface Serial0
encapsulation x25
ip address 192.200.10.2 255.255.255.0
x25 address 110102
x25 htc 16
x25 nvc 2
x25 map ip 192.200.10.1 110101 broadcast
x25 map ip 192.200.10.3 110103 broadcast
!
Router:
interface Serial0
encapsulation x25
ip address 192.200.10.3 255.255.255.0
x25 address 110103
x25 htc 16
x25 nvc 2
x25 map ip 192.200.10.1 110101 broadcast
x25 map ip 192.200.10.2 110102 broadcast
!
【问题1】X.25网络设备分为哪几类?
【问题2】解释配置中画线部分内容含义?

习题四

以下是使用E1线路实现多个64K专线连接.
注: 1. 当链路为T1时,channel-group编号为0-23, Timeslot范围1-24; 当链路为E1时, channel-group编号为0-30, Timeslot范围1-31.;
路由器具体设置如下:
Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname router1
!
enable secret 5 $1$XN08$Ttr8nfLoP9.2RgZhcBzkk/
enable password cisco
!
!
ip subnet-zero
!
controller E1 0
framing NO-CRC4
channel-group 0 timeslots 1
channel-group 1 timeslots 2
channel-group 2 timeslots 3
!
interface Ethernet0
ip address 133.118.40.1 255.255.0.0
media-type 10BaseT
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0:0
ip address 202.119.96.1 255.255.255.252
encapsulation hdlc
no ip mroute-cache
!
interface Serial0:1
ip address 202.119.96.5 255.255.255.252
encapsulation hdlc
no ip mroute-cache
!
interface Serial0:2
ip address 202.119.96.9 255.255.255.252
encapsulation hdlc
no ip mroute-cache
!
no ip classless
ip route 133.210.40.0 255.255.255.0 Serial0:0
ip route 133.210.41.0 255.255.255.0 Serial0:1
ip route 133.210.42.0 255.255.255.0 Serial0:2
!
line con 0
line aux 0
line vty 0 4
password cicso
login
!
end

【问题1】E1和CE1的主要区别是什么?
【问题2】解释配置中画线部分内容含义。

习题五

阅读以下有关网络设备安装与调试的叙述,分析设备配置文件,回答问题 1、问题 2 和问题 3,把解答填入答题纸的对应栏内。
现以一台远程访问服务器(RAS,Remote Access Server)Cisco 2509、RJ45 为例来说明。
第一步,预备安装与调试所需的设备,主要包括 RAS---Cisco 2509、RJ45 直通线,RJ45 转 9 针串口转换器、计算机。
第二步,硬件连接,RJ45 直通线一头插入 Cisco 2509 的 console 口,另一头接 RJ45 转 9 针串口转换器,·再将转换器接到计算机的串口。
第三步,RAS加电,在计算机上调用 Windows 98 下的超级终端程序,配置设备连接参数,以便进入Cisco 设备的虚拟操作台。
第四步,输入 Cisco 2509 的 IOS 配置命令。
第五步,将调试完毕的设备连人本地网络,通过拨号验证配置是否正确。

【问题1】
在 RAS 上存在着两个 RJ45 的端口,分别为“console”与“AUX”,请问这两个端口的用途是什么? (控制在100个字以内)


【问题2】
在调用超级终端程序进行设备连接时,应该对设备的连接参数进行正确设置,参数主要包括串口数据传输率、数据位数。停止位数以及是否有奇偶校验。清给出正确的连接参数,以便进入 Cisco 设备的虚拟操作台,进行设备调试。 (控制在100个字以内)

【问题3】
在第四步中,进入虚拟操作台后,在 IOS 环境下输入了如下的配置,请解释【1】~【4】处的标有下划线部分配置命令的含义(“◇”后为配置内容,“★”和“//”后为注释内容)
★ 配置服务器信息
◇; hostname; Cisco 2509;//服务器名称
◇; enable; secret******;//特权口令
◇; ip domain-manl wxx.edu.cn;;//设置拨号服务器所属域名
◇; ip-name-server; 202.112.77.2; //设置拨号服务器 DNS
【1】 (此处有3条下划线)
◇; async-bootp subnet-mask 255.255.255.0
◇; async-bootp gateway 202.112.77.254
◇; async-bootp dns-server 202.112.77.2
★ 配置Ethenlei; Port;;;(略)
......
★ 配置动态分配的地址池
◇; ip local pool pool2509 202.112.79.1; 202.112.79.8; //定义 iP 地址池
★ 配置 Asynchronous Interface
//异步口是 RAS 服务器上连接 modem,用于用户拨号的端口
interface Group-Async 1; //对第一组异步接口进行配置,对异步口的配置可以按 组,也可以按单个口
group-range 1 8; //划定 1 到 8 号异步口属于第一组
encapsulation pap; //加载点到点协议
【2】 (此处有2条下划线)
ansync dynamic address
ansync default address pool pool2509 //pool2509的定义见“配置动态分配的地址池”部分
ppp; authentication pap //设置 ppp 的验证方式为用户口令方式
★ 配置 router 信息
【3】 (此处有3条下划线)
◇; router rip
network 202.112.77.0
network 202.112.79.0
★ 配置拨号服务器的缺省路由;;;;;(略)
......
★ 配置存取用户组
◇; access-list 1 pormit 202.112.77.0.0.0.255; //定义用户组的范围
★ 配置Asynchronous PORT(略)
★ 配置 vty
◇; Iine vty 0 4; //配置虚拟终端
【4】 (此处有3条下划线)
access-class 1 in; //access-class的定义见“配置存取用户组”
pasword ******
login

习题六

IPSec的配置与测试。

【问题1】简述IPSec实现VPN的工作流程

【问题2】解释配置中画线部分含义。

网络拓扑:

路由器之间的地址分配表如下:
总部;分支机构
内部网段网号;172.22.1.0;172.22.2.0
互连网段网号;168.1.1.0;167.1.1.0
路由器内部端口ip地址;172.22.1.100;172.22.2.100
路由器internet端口ip地址;168.1.1.1;167.1.1.1
路由器串口ip地址;202.96.1.1;202.96.1.2
隧道端口ip地址;192.168.1.1;192.168.1.2
两端路由器的配置分别如下:
总部端路由器的部分配置:
crypto isakmp policy 1
authentication pre-share
group 2
crypto isakmp key test123 address 202.96.1.2
crypto ipsec transform-set VPNtag ah-md5-hmac esp-des
crypto map VPNdemp 10 ipsec-isakmp
set peer 202.96.1.2
set transform-set VPNtag
match address 101
!
interface Tunnel0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
tunnel source 202.96.1.1
tunnel destination 202.96.1.2
crypto map VPNdemo
interface serial0/0
ip address 202.96.1.1 255.255.255.252
no ip directed-broadcast
crypto map VPNdemo
!
interface Ethernet0/1
ip address 168.1.1.1 255.255.255.0
no ip directed-broadcast
interface Ethernet0/0
ip address 172.22.1.100 255.255.255.0
no ip directed-broadcast
!
ip classless
ip route 0.0.0.0 0.0.0.0 202.96.1.2
ip route 172.22.2.0 255.255.0.0 192.168.1.2
access-lost 101 permit gre host 202.96.1.1 host 202.96.1.2

分支机构端路由器部分配置:
crypto isakmp policy 1
authentication pre-share
group 2
crypto isakmp key test123 address 202.96.1.1
crypto ipsec transform-set VPNtag ah-md5-hmac esp-des
!
crypto map VPNdemo 10 ipsec-isakmp
set peer 202.96.1.1
set transform-set VPNtag
match address 101
!
interface Tunnel0
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
tunnrl source Serial0/0
tunnel destination 202.96.1.1
crypto map VPNdemo

interface Serial0/0
ip address 202.96.1.2 255.255.255.252
no ip directed-broadcast
crypto map VPNdemo
!
interface Ethernet0/1
ip address 167.1.1.1 255.255.255.0
no ip directed-broadcast
interface Ethernet0/0
ip address 172.22.2.100 255.255.255.0
no ip directed-broadcast
!
ip classless
ip route 0.0.0.0 0.0.0.0 202.96.1.1
ip route 172.22.1.0 255.255.0.0 192.168.1.1
access-lost 101 permit gre host 202.96.1.2 host 202.96.1.1


发表评论 共有条评论
验证码: