学电脑,学计算机 | 手机访问 | 加入收藏 | 设为首页 | RSS
当前位置:首页 > 网络技术 > 交换技术 > 正文

关于VLAN中DHCP域的问题

发布时间:2009-06-01 00:37:51  来源:本站整理
【摘要】: 关于VLAN中DHCP域的问题

我的问题就是如何给每个VLAN 指定各自的DHCP 域。比如vlan 2 对应dhcp test2 vlan3 对应dhcp test3. 假如:;;;

情况1: 现在有一个router 上做了多个DHCP 域.; ;

然后在switch 上划VLAN 。那么那个交换机上的ip help-address 的IP 是什么呢?是router 上哪个口的IP 呢? 如:在router 上的配制:;;

ip dhcp excluded-address 10.0.199.200 10.0.199.254 ! ip dhcp pool test 1 network 10.0.199.0 255.255.255.0 default-router 10.0.199.1 dns-server 10.0.199.252 lease 0 0 5; ;

ip dhcp pool test 2 network 10.0.200.0 255.255.255.0 default-router 10.0.200.1 dns-server 10.0.199.252 lease 0 0 5; ;

在交换机上:;;

interface Vlan199 ip address 10.0.199.1 255.255.255.0 ip helper-address ???????????????; ;

int vlan 200; ;

ip address 10.0.200.1 255.255.255.0 ip helper-address ??????????? 这时在这里指定的helper-address 是什么呢?才能把vlan199 和vlan200 里的电脑取得相; ;

应DHCP scope???;;;

第二种情况:利用局域网中的win2000’s DHCP server 假如dhcp server 的ip 192.168.10.1 在DHCP 上划分两个scope.; ;

第一个scope 192.168.10.10 -----192.168.10.255 第二个scope 192.16.20.10 ------192.16.20.255.; ;

交换机划分VLAN 之后,如何保证DHCP 服务器使用仍然在其它区域起作用。即VLAN10 里的机器取得第一个scope 里的ip: 即从192.168.10.10 -----192.168.10.255 同样,vlan20 取得相应第二个scope 里的IP. 这时在这里指定的helper-address 是什么呢? 才能把vlan199 和vlan200 里的电脑取得相应DHCP scope???;;;

第三种情况:假如在一个3550emi 上划分多个DHCP 域。由于它本身就可路由。并能划VLAN。那么这时在这里指定的helper-address 是什么呢?才能把vlan199 和vlan200 里的电脑取得相应DHCP scope???; ;

FW:ip dhcp pool valn x; ;

network x.x.x.x x.x.x.x; ;

default-router x.x.x.x;;

其中vlan x 这个pool 是全局pool 的子集;;

interface vlan x; ;

ip helper-address x.x.x.x; ;

The helper address can be a specific DHCP server address, or it can be the network address

if other DHCP servers are on the destination network segment. Using the network address enables other servers to respond to DHCP requests.; ;

If you have multiple servers, you can configure one helper address for each server.; ;

DHCP relay:; ;

http://www.cisco.com/en/US/prodUCts...00800c6ed2.Html;;;

FW: 以一个配置案例来做总结吧:

router1 的int fa0/0 上接有dhcp server 。和router2 通过s0/0 连接IP 地址方案如下:;;

route1:; ;

int fa0/0 10.1.1.254/24 int fa0/1 10.1.2.254/24 int s0/0 192.168.0.1/30 route2:; ;

int fa0/0 10.2.1.254/24 int fa0/1 10.2.2.254/24 int s0/0 192.168.0.2/30 dhcp server adderss:10.1.1.1; ;

配置:;;

router1: ! ip forward-protocol udp; ;

! int fa0/0 ip addr 10.1.1.254 255.255.255.0; ;

no shutdown ! int fa0/1 ip addr 10.1.2.254 255.255.255.0; ;

ip helper-address 10.1.1.1 no shut !; ;

int s0/0 ip addr 192.168.0.1 255.255.255.252 no shut; ;

encap ppp; ;

!; ;

ip route 10.2.0.0 255.255.0.0 192.168.0.2;  

! router2: !; ;

ip forward-protocol udp ! int fa0/0 ip addr 10.2.1.254 255.255.255.0; ;

ip helper-address 10.1.1.1 no shutdown !; ;

int fa0/1 ip addr 10.2.2.254 255.255.255.0 ip helper-address 10.1.1.1 no shut; ;

! int s0/0 ip addr 192.168.0.2 255.255.255.252; ;

no shut encap ppp ! ip route 10.1.0.0 255.255.0.0 192.168.0.1 ! dhcp server: scope 11: router:10.1.1.254; ;

scope 12: router:10.1.2.254 scope 21: router:10.2.1.254; ;

scope 22:; ;

router:10.2.2.254;;

使用VLAN 的情况配置与此相同。只不过把int fa 换成int vlan 而已。;;



你只需要将VLAN 当做是第N 个SCOPE 的ROUTE 选项就行了。;;

在你的交换机上按常规划分好VLAN:; ;

假设有:VLAN20 和VLAN30, 你先在交换机上划分好(这步应该都会做), 然后在路由器上设置VLAN 网关(假设是FA0/0.1:192.168.20.254/24 和FA0/0.2:192.168.30.254/24), 在VLAN20 接口和VLAN30 接口下分别设置ip help-address DHCP_SERVER_ADD,IP FORWARD UDP 等,其实DHCP_SERVER 接在哪里无所谓,只要能够ROUTE 通,就行。要害是DHCP_SERVER 上设置SCOPE 时,你分两个,其中一个为192.168.20.0 网段的,它的相应ROUTE 选项为192.168.20.254, 另一个SCOPE 为192.168.30.0 网段的,它的相应ROUTE 选项为192.168.30.254 。上述设置完成后,记得在两个网段都要能和DHCP_SERVER 通。



发表评论 共有条评论
验证码: